MACNOTES

Veröffentlicht am  28.07.09, 3:42 Uhr von  

Samsung Syncmaster via DVI mit OS X betreiben

Genauer hätte man formulieren müssen Syncmaster T240HD. Noch spezieller einschränken könnte man die Situation auf eine ATI Radeon 4870. Doch bei der Recherche zu einem persönlichen Problemfall wurde schnell klar, dass das Problem nicht auf einen einzigen Bildschirmtyp einzugrenzen ist, geschweige denn gewisse Serien und Typen von Apple-Rechnern oder bestimmte Grafikkarten. Doch bleiben wir zunächst bei dem speziellen Problemfall: Wer einen Samsung Syncmaster T240HD über dessen zugehörige DVI-Schnittstelle mit einer ATI Radeon 4870 verbinden will, stößt unter OS X auf Schwierigkeiten. Der Bildschirm meldet spätestens nachdem der graue Apfel-Bildschirm abgearbeitet wurde: “Kein Signal”.

Im Endverbraucherbereich sind Bildschirme von Samsung nicht zu selten anzutreffen. Was aber tun, wenn man den neu erworbenen Bildschirm nicht problemlos angeschlossen und ans Laufen bekommt? Der Laie, der sich einen Apple-Rechner kauft, wird zunächst ins Geschäft gehen, oder bei den Herstellern (Apple, ATI, Samsung) anrufen. Versiertere und neugierige Computernutzer, die der Sache selber auf den Grund gehen wollen, recherchieren im Internet und hoffen dort eine Lösung für ihr Problem zu finden.
 

Nur mit Adapter

Fakt ist: Aktuell gibt es für den speziellen Fall, einen Syncmaster T240HD per DVI-Schnittstelle unter OS X ans Laufen zu bekommen keine patente Lösung. Die einzige wirkliche Hilfe ist folgende: Ein Adapter muss her! Wer nämlich den Bildschirm nicht via DVI, sondern z. B. über einen von beiden HDMI-Anschlüssen oder etwa den VGA-Anschluss am Syncmaster betreibt, der kann das Gerät problemlos verwenden. Gleiches gilt wohl auch für den T240 (ohne HD) oder den T220 und auch andere Modelle in dieser Samsung-Serie. Aber nur deshalb mit Adapter oder ein spezielles Kabel, da ja die Radeon 4870 (sowie zuvor 4850) über einen DVI- sowie einen Mini-Displayport-Anschluss verfügen.

Es scheint so, als handelte es sich entweder um ein softwareseitiges Problem (Treiber, OS X) oder aber um einen hardwareseitigen Fehler (Bildschirm). Wer am Ende wem den Schwarzen Peter in die Schuhe schieben mag – der Dumme ist wohl der Kunde. Denn wir könnten uns darauf einigen, dass auf beiden Seiten nachgebessert werden sollte, damit es auf Anhieb funktioniert, zumal beispielsweise schon im Jahr 2004 OS X und Samsung-Monitore via DVI nicht die besten Freunde wurden.
 

Nicht jedes Kabel

Eigentlich müsste man sagen, trüge Samsung die Schuld. Doch derselbe Monitor – angeschlossen über seine DVI-Schnittstelle – funktioniert unter einer Boot Camp-Installation von Windows Vista problemlos. Im Kleingedruckten müsste stehen, dass der Monitor nur funktioniert, wenn man aktuelle Treiber installiert hat (oder Windows XP und davor einsetzt) und mindestens ein digitales Dual Link DVI-Kabel verwendet (vgl. Wikipedia). Digital deshalb, weil der Anschluss am Monitor ein DVI-D-Anschluss ist. Ein Dual Link-Kabel müsste es streng genommen nicht sein, mit einem einfachen Single Link-Kabel hat der Betrieb jedoch nicht funktioniert. Ob das Kabel grundsätzlich mit dem Eingang harmoniert merkt man recht schnell, wenn man es bei laufendem Betrieb am Rechner aus- und wieder einsteckt. Wenn der Monitor dann nicht zumindest eine Rückmeldung gibt, bzw. aus dem Standby kurz in den aktiven Modus wechselt, um dann mitzuteilen, dass er kein Signal kriegt, hat man definitiv ein falsches DVI-Kabel zum Betrieb des Syncmaster (und anderer). Funktioniert zumindest das, weiß man, dass die Kommunikation zwischen Monitor und Rechner sicher gestellt ist. Dass dann allerdings der Monitor just in dem Moment, da die grafische Benutzeroberfläche (GUI) geladen werden soll, “Kein Signal” als Rückmeldung gibt, und wieder in den Standby wechselt deutet ab dem Moment auf ein Softwareproblem hin. Das ist zumindest aktuell (Ende Juli 2009) die Situation vor der man steht und die man bislang nicht ändern kann. Abhilfe schafft eben nur, den Monitor über eine andere Schnittstelle anzusprechen.
 

Apple-Adapter sind tückisch

Bei den Recherchen nach einer Lösung hat sich allerdings gezeigt, dass zum einen nicht nur diese Serie von Samsung dazu neigt nicht hundertprozentig über der DVI-Schnittstelle mit OS X zu kommunizieren. Vielmehr sind noch weitere Samsung-Bildschirme, aber wohl auch Bildschirme anderer Hersteller betroffen (DELL, Benq). Aber eben jeweils nur, wenn man versucht sie via DVI zu verbinden.
Trickreich ist zudem die Situation mit Apples hauseigenen Adaptern (Mini-DVI, Mini-Displayport usf.). Wer beispielsweise einen der genannten Bildschirme als externen Monitor für ein aktuelles Macbook (Pro) verwenden wollte, der müsste darauf achten, dass der standard Mini-Displayport auf DVI-Adapter offenbar nicht alle diejenigen Signale durchschleift, die notwendig sind. In einem Apple-Support Forum fand sich ein Hinweis auf dieses Phänomen mit einer ganz anderen Konfiguration als derjenigen, die zum Schreiben des Artikels führte. Doch ließ sich das geschilderte Problem reproduzieren, denn die ATI Radeon 4870 in der Ausführung für Macs verfügt über einen Mini-Displayport-Anschluss und einen DVI-Anschluss. Das DVI-Kabel, das die Kommunikation zwischen Grafikkarte und Bildschirm hinbekam (Funktion unter Windows), verweigerte den Dienst wieder, sobald der Apple-Adapter dazwischen geschaltet wurde.
 

Wald vor lauter Bäumen

Wer die Apple Support-Foren durchkämmt, der wird eine Vielzahl von Problemkonstellationen finden. Ich habe ein ganzes Wochenende damit zugebracht dort und anderswo zu lesen und eigene Versuche nach dem Ausschlussverfahren haben mich nach und nach das Problem immer weiter einkreisen lassen. Leider hat nicht jeder immer die richtigen Kabel zur Hand, geschweige denn denkt man immer sofort daran, wie man als nächstes vorgehen kann.

Wer Schwierigkeiten hat, seinen Monitor bzw. sein TFT-Display unter OS X zum Laufen zu kriegen, der sollte zunächst überprüfen, ob es wirklich ein generisches Problem mit Apples Betriebssystem ist. Will heißen, wenn der Monitor unter Windows z. B. ebenfalls nicht funktioniert, kann man sich bei der Recherche nach Lösungen anders orientieren. Das ist immens wichtig, weil man ansonsten schnell in eine Sackgasse tappt und nicht weiterkommt. Man kann in der Folge versuchen, die Grafikkarte oder den Bildschirm selbst, aber auch etwaige Adapter oder Kabel als Ursache auszumachen. Bei meinen Recherchen bin ich auf Fälle gestoßen, in denen der einfache Wechsel des Kabels schon geholfen hat. Wann man unter OS X Monitore der Serie T2** mittels DVI problemlos wird anschließen können, bleibt abzuwarten.
 

Geht auch

ATI könnte etwas an der Treibersituation verändern müssen, weil es unter Vista, XP und anderen klappt. Samsung müsste vielleicht nachbessern, weil es nicht das erste Mal ist. Und Apple müsste an der Implementierung arbeiten, da solche und ähnliche Probleme in den Support-Foren schon diskutiert wurden. Allerdings entsteht oftmals kein Handlungsdruck bei den Beteiligten Herstellern, wenn nicht gehäuft ähnliche oder identische Problemschilderungen vorgebracht werden. Das heißt konkret: Auch wenn man ein Work Around oder eine Lösung für ein Problem findet, sollte man in irgendeiner Form den Hersteller informieren. Je mehr Nutzer das tun, desto größer wird die Einsicht bei den Beteiligten, dass es sich nicht um Einzelfälle handelt. Zur Ehrenrettung aller drei Firmen sei gesagt, dass ein anderes Display bei mir zum Einsatz kommt (Syncmaster 2493HM), das sich sehr wohl via DVI auch unter OS X und sogar mit Apples Mini-Displayport auf DVI-Adapter einsetzen lässt.

 Und wie ist deine Meinung?  Schreib uns einfach!

 11 Kommentar(e) bisher

  •  @superglide sagte am 28. Juli 2009:

    RT @Macnotes: Samsung Syncmaster via DVI mit OS X betreiben http://macnot.es/13215

    Antworten 
  •  Ande sagte am 28. Juli 2009:

    Sehr interessanter Artikel, danke.
    Ich habe hier auch so eine Kombination die mir Rätsel aufgibt. Einen Samsung T260HD und ein aktuelles MBP.
    Folgende Möglichkeiten:
    1. MBP mit Mini-DisplayPort und DVI auf DVI: kein Signal
    2. anderes MBP vom Kollegen: kein Signal
    3. gleicher Adapter gleiches Kabel aber Mac mini: alles ok
    4. anderer Monitor von Philips: bei beiden Rechnern alles ok
    5. Macbook white mit mini DVI auf DVI: alles ok
    6. verschiedene DVI Kabel versucht: keine Chance mit MBP

    Jetzt betreibe ich den Monitor mit einem DVI auf HDMI Kabel und es klappt problemlos, außer der Tatsache, dass jedes mal, wenn der Bildschirm in den Ruhezustand geht man danach die Auflösung neu einstellen muss.

    Antworten 
  •  DB sagte am 28. Juli 2009:

    Du schreibst, dass die Belegung des Adapters evtl. nicht ausreichend ist. Es gibt auch 3rd Party Display-Adpater. Bspw. von Mini Displayport auf DVI.

    Und mal was ganz: Hatten die Nicht-NVIDIA GeForce 9400M überhaupt schon einen Mini Displayport?

    Antworten 
  •  at sagte am 28. Juli 2009:

    @Ande: Es gibt ein Tool für OS X, SwitchresX – damit kannst du für Monitore Auflösungen einstellen und speichern und noch viel mehr. Speichern aber nur wenn man die Shareware registriert. Das Tool kostet 14 Euro. Vielleicht eine Überlegung wert, wenn man nicht jedes Mal neu einstellen mag. Mittelfristig sollte aber wohl Apple hier im OS nachbessern, damit man die Einstellungen nicht jedes Mal neu machen muss. Das Tool (http://www.madrau.com/SRX3/html/SRX/About.html) kann aber noch mehr Dinge.

    @DB: Wie meinst du das mit den GeForce?

    Antworten 
  •  at sagte am 28. Juli 2009:

    @DB: Ah jetzt ja – ich hab’s kapiert. *G* Erst der Unibody hat den Mini-Displayport eingeführt in der Macbook-Reihe eingeführt. Allerdings haben die Plastik-Macbooks noch immer den Mini-DVI-Anschluss. Und die älteren Macbook Pros hatten sogar DVI-Anschlüsse. Also im Prinzip gibt’s da – Apple sei Dank – einen großen Wust an Anschlüssen.

    Dieser Adapter (Mini-DVI auf DVI) könnte aber auch betroffen gewesen sein, nicht mit jedem Kabel zu funktionieren, bzw. nicht alle Signale durchzuschleifen. Zumindest hab ich auch diese Adapter in den Support-Foren bei Problembeschreibungen gesehen. Also wohlgemerkt auch da nur der Mini-DVI auf DVI. Mini-DVI auf VGA oder andere sind nicht betroffen gewesen. Ein Kommentar lautete, dass die DVI-Seiten des Adapters nicht vollständig belegt wären und keine digitalen Signale durchschleifen würden.

    Antworten 
  •  DB sagte am 29. Juli 2009:

    @at
    Genau. Die neuen MBPs, auch die kleinen 13er, haben alle einen Mini-Displayport.

    Ich selbst hatte ein ähnliches Problem damals mit meinem weißen MacBook. Hier hatte ich auch einen externen Monitor per Mini-DVI auf DVI-Adapter betrieben. Bild wurde irgendwann beim Booten dunkel.

    Allerdings war nicht der Adapter oder irgendwelche Kabel das Problem, sondern der Monitor selbst. Nach dem ich ihn in den Service gab und wieder repariert zurück bekam, war das Problem behoben.

    Antworten 
  •  minturno sagte am 17. August 2009:

    ich habe das gleiche Problem mit dem Nec LCD 26″ WUXi. Die probleme tauchten auf beim Upgrade auf ATI 4870. Ich dachte zunächst, dass es an der neuen Karte liegt, da ich vorher mit der 2600XT keine Probleme mit diesen Bildschirm hatte. Nun stellte ich aber fest, dass die Probleme jetzt auch mit der 2600er auftauchen und damit offensichtig durch eine eine Softwareumstellung seites Apple hervorgebracht worden sind. Leider sieht es nicht danach aus, dass es schnell eine Lösung dazu geben wird.

    Antworten 
  •  at sagte am 17. August 2009:

    @minturno: Das stimmt, zumindest wohl keine Lösung auf die wir terminlich Einfluss nehmen könnten.

    Antworten 
  •  Marcus sagte am 24. September 2011:

    Hi,
    sorry ich muss mal rückfragen! Leider habe ich mein MacBookPro noch relativ frisch und wollte den nun mit meinem Samsung T per DisplayPort/HDMI verbinden. Leider sagt er immer “Kein Signal”. Was muss ich tun? Hoffe, dass mir hier jemand helfen kann auch wenn die Einträge schon älter sind.
    Dank&Gruß
    Marcus

    Antworten 
  •  Patrik Hodapp sagte am 27. Januar 2013:

    Ich habe bisher gedacht ich hätte ein Problem mit meiner Grafikkarte weil ich im Dual-DVI Betrieb kein Bild angezeigt bekomme.

    Nun habe ich einen einen neuen PC und habe meinen TD260HD an dessen DVI-D Port angeschlossen. Ich bekam kein Signal, kein Boot oder Bios Screen.

    Daraufhin habe ich es mit einem anderen DVI Kabel versucht – selbes Ergebnis.

    Anschliessend habe ich die beiden DVI Kabel mit einem HP Monitor benutzt und bekomme dabei jeweils ein Bild mit besagtem PC. Wenn ich meinen alten PC über dessen Graka an den TD260HD anschliesse geht wieder alles.

    Ich kann nicht verstehen warum ein DVI-D Signal einmal verarbeitet wird und einmal nicht. Es handelt sich dabei wie gesagt um das Boot und BIOS Bild, also kann es keine Treiber-Ursache haben. Warum verbeitet der Monitor das Signal einmal und einmal nicht?

    Antworten 
    •  at sagte am 28. Januar 2013:

      Also auch das BIOS ist ja Software, und dein PC/Mainboard hat ja eine Firmware. Entsprechend kann es schon sein, dass ein PC nicht mit einem Monitor zurechtkommt, bzw. mit einer Leitung, wenn die Anschlüsse falsch gepolt sind. Das sollte zwar nicht vorkommen, aber es gibt eigtl. nix, was es nicht gibt. Vielleicht gibt es für den neuen PC ein BIOS/Firmware-Update?

      Antworten 

Kommentar verfassen

 0  Tweets und Re-Tweets
       0  Likes auf Facebook
         0  Trackbacks/Pingbacks
          Werbung
          © 2006-2013 MACNOTES.DE. Made with insanely great for all things Mac. Apple.de