MACNOTES

Veröffentlicht am  17.02.10, 11:02 Uhr von  

Aperture 3: Speicherleck verlangsamt System und begünstigt Abstürze

ApertureDas gerade mal eine Woche verfügbare Aperture 3 zeigt bereits Probleme mit Speicherlecks. Dies betrifft unter anderem den virtuellen Speicher, der sich teilweise selbstständig so stark erweitert, dass die Software sämtlichen freien Speicher auf der Festplatte verbraucht.

Die Folgen der Speicherlecks: Der Rechner wird langsamer, im schlimmsten Fall friert das System komplett ein. Eine Quelle für das Problem konnte bisher nicht verortet werden, allerdings gibt es Tasks, die die Speicherschwierigkeiten begünstigen können: Unter anderem treten sie nach dem Import älterer Bildergalerien und beim Aktivieren der Faces-Funktion auf. Bei einigen Nutzern zeigen sich die Speicherprobleme bereits direkt nach dem Start, bei manchen wiederum gar nicht, was die Frage aufwirft, ob die vorhandene Hardware oder andere genutzte Programme Ursache sein können. Die einzige bisher vorhandene Lösung besteht darin, Aperture nur im 32-bit-Modus zu nutzen, da dort die Menge des nutzbaren Speichers begrenzt ist. Den 32-bit-Modus kann man im Finder-Informationsfenster zu Aperture 3 (Programmicon klicken, Command-I drücken) mit Hilfe einer Checkbox aktivieren.

[via Apple-Forum]

 Und wie ist deine Meinung?  Schreib uns einfach!

 16 Kommentar(e) bisher

  •  Pudi sagte am 17. Februar 2010:

    Faces hat meinen Rechner so unnormal langsam gemacht, ich hab gedacht ich rast’ aus. Hammer, echt. Aber dann bin ich ja nicht der einzige…

    Antworten 
  •  emefka sagte am 17. Februar 2010:

    Gottseidank hat man das jetzt endlich erkannt – ich hab schon verzweifelt nach ALLEM möglichen gesucht.

    Wenigstens hat man es jetzt erkannt und kann sich an die Bearbeitung machen.

    Dann stell ich jetzt den 32Bit-Modus ein und warte auf das Update.

    Antworten 
  •  kg sagte am 17. Februar 2010:

    @Pudi @emefka ob es nun beruhigend oder doch beunruhigend ist, dass der Fehler jetzt bekannt ist, da bin ich mir noch unschlüssig. Offenbar wurde die Software nicht anständig und umfassend getestet, ansonsten hätte sowas auffallen müssen, meines Erachtens. Sowas sollte man von einer Software der Größenordnung erwarten dürfen.

    Antworten 
  •  Diga sagte am 17. Februar 2010:

    Das ist zwar eine unbefriedigende Situation, aber grundsätzlich bin ich froh, dass der Fehler festgestellt wurde. Ich habe bemerkt, das mein MBP sehr langsam geworden ist, hab es allerdings auf MacFuse/NTFS-3G zurückgeführt, was ja recht “wackelig” ist, und das ich ungefähr zur gleichen Zeit installiert habe.

    Antworten 
  •  kg sagte am 17. Februar 2010:

    @Diga das einzige Problem ist, dass Apple den Fehler offiziell noch gar nicht bestätigt hat, entsprechend bin ich mal gespannt, wie die sich äußern werden und vor allem wann da ein Update kommt.

    Antworten 
  •  bosch sagte am 17. Februar 2010:

    Mal ganz doof gefragt: Wie stellt man denn den 32-Bit-Modus ein?

    Antworten 
  •  kg sagte am 17. Februar 2010:

    @bosch das ist keine doofe Frage, die ist absolut gerechtfertigt und wird von uns postwendend beantwortet: Im Finder das Infofenster zu Aperture 3 aufrufen, dort gibt es eine Checkbox “Im 32-bit-Modus starten”. Sollte die Checkbox fehlen, einmal im Safe Modus booten, danach nochmal neustarten und die Box sollte da sein.

    Antworten 
  •  Michael Berlin sagte am 17. Februar 2010:

    Ich bin eines der Opfer dieses Problems. Ich habe ca. 50.000 Bilder in der alten A2 Datenbank gespeichert, die mit den Vorschaubildern dafür letztendlich 80GB groß ist. Das geringere problem ist, daß dann nochmal 80 GB Festplattenplatz für die Migration benötigt werden, es geht bei MacBooks daher in der Regel wohl nur, indem man die Bibliothe vorher auf eine externe Festplatte auslagert. Das größere problem ist in der Tag, daß der RAM Speicherbedarf fast in das unendliche ansteigt, bei mir wurden über 60 GB RAM-Bedarf vom System angezeigt, von denen aber nur 4 GB durch meinen eingebauten RAM Speicher befriedigt werden können, der rest wird auf die Festplatte ausgelagert und hin- und her geschaufelt. Nach 4 Tagen habe ich diesen ganzen Prozess abgebrochen, die alte A2 Datenbank ist zwar nicht kaputt, aber die Migration ist praktisch unmöglich. Was ich noch nicht versucht habe ist, den prozess im 32 BIT mode zu starten, aber eigentlich habe ich keine Lust mehr auf Experimente und hoffe jetzt, daß es ein Update gibt.

    Antworten 
  •  @schoobidoo sagte am 19. Februar 2010:

    Ob ich wohl auf #aperture 3.0.1 warten sollte? http://macnot.es/32692 http://yfrog.com/4fm69vj

    Antworten 
  •  bernd sagte am 20. Februar 2010:

    ich finde in der infobox zu aperture3 keine checkbox für den 32bit-betrieb!

    Antworten 
  •  bernd sagte am 21. Februar 2010:

    falls das für jemanden auch interessant ist: wenn die 32bit-checkbox nicht mehr zu sehen ist, sorgt ein start im safe-mode und ein anschließender neustart dafür, daß man aperture wieder im 32bit-modus starten kann.

    Antworten 
  •  andidiplo sagte am 23. Februar 2010:

    Bei mir(neuer iMac 27Core i5 mit Syst.10.6.2) stürzte Aperture 3.0 am Anfang ständig ab und löschte den Systemlink zu Screensaver und iTunes für das iPhone.Also keine Pausenbilder mehr aus Aperture möglich. Erst nach Deinstallation mit “CleanApp” und kompletter Neuinstallation (natürlich vorher Backup!) lief es. Allerdings installierte es unter user/Bilder eine verborgene Mediathek von 93 GB, die ich nur entdeckte, weil die Summe der Festplatte nicht mehr stimmte.Statt 270GB vor Installation waren vom System plötzlich 363 belegt. Über Terminal musste ich die verborgene Datei finden und die 93 GB löschen. Jetzt scheint Alles zu stimmen, aber es bleibt irgendwie ein komisches Gefühl. Dieses Programm ist noch nicht ausgereift!

    Antworten 
  •  Nikko1976 sagte am 24. Februar 2010:

    Im Grunde genommen gefällt mir Aperture sehr und ich arbeite gern damit. Doch leider muss ich meine anfänglich gute Meinung über Aperture 3 revidieren. Es ist echt ein Speicherkiller. Mit Abstürzen muss immer gerechnet werden.

    Ich habe jetzt gerade zwei Bilder mit dem Retusche-Werkzeug bearbeitet. Erst funktionierte es noch ganz gut, dann immer zögerlicher. Der gesamte freie Arbeitsspeicher wurde belegt! Das Rad, das in Aperture anzeigt, dass eine Verarbeitung stattfindet, drehte sich unaufhörlich. Schließlich meldete die Aktivitätsanzeige, dass Aperture nicht mehr reagiert.

    Also, ich muss sagen: eine schwache Leistung von Apple und eigentlich eine Frechheit, ein Programm mit solchen Mängeln auf den Markt zu werfen! Ich bin “nur” Hobby-Fotograf, wie soll denn ein Profi damit arbeiten? Kein Wunder, wenn Apple noch weitere Marktanteile an Lightroom verliert!

    Antworten 
  •  Nikko1976 sagte am 24. Februar 2010:

    Aperture Update 3.0.1 ist da!

    Antworten 
  •  emefka sagte am 24. Februar 2010:

    da bin ich ja mal gespannt ob das funktionert und die bekannten Fehler behebt – die Changelist ist ja schonmal beachtlich!

    *ichinstalliere*

    Antworten 
  •  emefka sagte am 24. Februar 2010:

    Oh mein Gott.
    Es fühlt sich bereits nach 30 Minuten scho soviel besser an.

    Geschwindigkeit beim Brushen ist zwar immer noch lame – aber jetzt läuft es wenigstens seit 30min ohne einen Absturz!

    Antworten 

Kommentar verfassen

 0  Tweets und Re-Tweets
       0  Likes auf Facebook
         1  Trackback/Pingback
        1. Aperture 3: Update behebt Speicherprobleme nur bedingt am 25. Februar 2010
        Werbung
        © 2006-2013 MACNOTES.DE. Made with insanely great for all things Mac. Apple.de