MACNOTES

Veröffentlicht am  23.08.11, 14:31 Uhr von  Alexander Trust

OS X Lion: WLAN-Problem nach dem Aufwachen beheben

Mac OS X Lion Mac OS X Lion

Seit der Veröffentlichung von OS X Lion haben Anwender über Probleme im Zusammenhang mit der WLAN-Verbindung geklagt. Besonders nach dem Aufwachen aus dem Ruhezustand hat das Wiederherstellen der Verbindung bei manchen Konfigurationen relativ zuverlässig nicht funktioniert. Das Update auf OS X Lion 10.7.1 versprach Besserung, geholfen hat es in der Regel nicht. Wir zeigen, wie man das Problem für manche Konfigurationen beheben kann.

Schon kurz nach der Veröffentlichung von OS X Lion machte sich erster Unmut unter den Anwendern breit: Die neuen Features wissen zu gefallen. Aber nach dem Aufwachen aus dem Ruhezustand konnte die WLAN-Verbindung nicht selten nicht korrekt wieder hergestellt werden. Entweder wurde die Drahtlos-Netzwerkverbindung gar nicht gefunden, oder sie wurde gefunden, aber es bestand kein Zugriff auf das Internet. Manchmal war die Signalstärke nur sehr schwach und in seltenen Fällen hat sogar das Vergeben einer IP-Adresse versagt (Ausrufezeichen am Wi-Fi-Icon in der Menüzeile). Das Update auf OS X Lion 10.7.1 versprach Hilfe, konnte dieses Versprechen jedoch nicht einlösen.

Dieses Phänomen tritt weder mit dem iPhone auf, noch mit einem weiteren Laptop und selbst mit “demselben” MacBook unter OS X 10.6 Snow Leopard war davon nichts zu spüren. Macnotes-Leser XPert hat inzwischen mithilfe des Apple-Supports eine Lösung gefunden. Der Hotline zufolge soll man folgendes probieren:

  1. Router vom Strom trennen.
  2. AirPort Express vom Strom trennen.
  3. MacBook ausschalten.
  4. MacBook wieder einschalten, dabei Cmd+Alt+P+R gedrückt halten (Apple-Jingle ist zweimal zu hören).
  5. Verbindung wiederherstellen.

Das war heute Vormittag gegen 9 Uhr, seither verbindet sich das MacBook wieder klaglos mit dem örtlichen Drahtlos-Netzwerk, selbst nach dem Ruhezustand.

Was wurde getan?

Die Tastenkombination Cmd+Alt+P+R beim Starten leert den PRAM und den NVRAM (siehe Erklärung von Apple). Der NVRAM hat beim Mac dieselbe Aufgabe wie bei einem PC, das Konzept ist schon relativ alt. Er speichert im Wesentlichen die Hardware-Konfiguration, sodass Adressierungen nicht noch einmal neu initialisiert werden müssen, wenn sich ohnehin nichts an der Konfiguration geändert hat. Dies beschleunigt den Startvorgang.

Der PRAM speichert einzelne Parameter eines Macs, beispielsweise die Lautstärke oder das Start-Volumen, von dem der Mac booten soll. Vor Mac OS X hat der PRAM noch sehr viel mehr gespeichert (vgl. Knowledge-Base).

Durch das Leeren der beiden Speicher wird der Rechner beim nächsten Hochfahren gezwungen, all jene Daten neu zu erarbeiten. Dabei werden Inkonsistenzen berichtigt.

Pikanterweise hat Apple nur eine Art Workaround im Angebot, keine tatsächliche Lösung. Der Support sagte, dass die Apple-Techniker noch nach der Ursache fahnden. Dass Anwender mit AirPort-Access-Points gleichermaßen Probleme haben wie Anwender mit anderen Wi-Fi-Hotspots, schließt zwar ein paar Dinge aus, hilft in dem Fall aber nicht wirklich weiter.

Das Setup

Natürlich ist bei solchen Erklärungen die Versuchsanordnung nicht ganz unwichtig, daher hier kurz, um welches Ökosystem es sich bei Leser XPert handelt: Er besitzt ein MacBook in Weiß (Ende 2009), AirPort Express und einen Siemens-Router mit T-DSL 16000, sowie OS X 10.7.1 (Update von Snow Leopard auf Lion).

Weitersagen

 Und wie ist deine Meinung?  Schreib uns einfach!

 29 Kommentar(e) bisher

  •  hack2learn sagte am 23. August 2011:

    Sehr geil, danke für den Hinweis ;)

    Antworten 
  •  Fischmuetze sagte am 23. August 2011:

    MacBook Alu 13″ Late 2008 hat das gleiche Problem. Wenn man SEHR SEHR geduldig ist, dann “repariert” sich aber die Verbindung nach dem Aufwachen von selbst

    Antworten 
  •  legi sagte am 23. August 2011:

    Bei mir war es anfangs auch extrem schlimm. Netz zwar häufig gefunden, aber immer TIMEOUT. Das Update hat rein gar nichts gebracht. PRAM Reset bei mir auch nicht.
    Habe dann Lion komplett neu von DVD auf eine frisch formatierte Platte installiert. Seitdem läuft lion viel flotter und WLAN-Probleme scheinen der Vergangenheit anzugehören.

    Antworten 
  •  iKasch sagte am 23. August 2011:

    Funktioniert nicht. Habe ein MacBook 2011 und das beschriebene Problem seit anfang an. Kenne auch die PRAM Reset Methode schon länger und in der Tat funktioniert es ein paar Stunden. Aber früher oder später wird es wieder auftreten .. zumindest ist es bei mir so. Ich bekomme das Problem einfach nicht los und es ist sehr nervig …

    Antworten 
  •  DasIch sagte am 23. August 2011:

    Selbes Problem mit meinem Macbook Air late 2010.

    Problem: Verbindung zum Router besteht, allerdings mit Ausrufezeichen (keine Internetverbindung)

    Lösung: WLAN am Macbook deaktivieren, 2 – 3 Sekunden warten, und erneut aktivieren.

    Antworten 
  •  g4tom sagte am 23. August 2011:

    Ich hatte das Problem an einer Airport Extreme sowohl per LAN als auch WLAN (2009er iMac 24″). Die Netzwerkverbindung deaktivieren und wieder aktivieren half, nervte aber. Seit 10.7.1 habe ich das Problem mit LAN nie wieder gehabt, insofern hat das Update bei mir schon was gebracht. Andernfalls wäre ich wahrscheinlich auf SL zurück, da ich meinen Rechner viele Male am Tag in den Ruhezustand schicke.

    Antworten 
  •  Pinkii sagte am 23. August 2011:

    WLAN Problem damit gelöst, vielen Dank.
    Was jetzt noch nervt ist, dass Programme (iPhoto, Pages oder Numbers) erst dann völlig gestartet sind, wenn die externen USB und Firewire Platten angelaufen sind. So lange habe ich den lustigen bunten Ball auf dem Screen, das war unter 10.6 nicht so! Woran mag das liegen?

    Antworten 
  •  Kevin sagte am 24. August 2011:

    - Mac Book Pro late 2010 (7.1)
    – OSX Snow Leo Upgrade (mittlerweile aber Lion frisch neuinstalliert)
    – Ubuntu Server als WLAN Access Point

    Problem ist bei mir gar nicht erst aufgetreten. Ich könnte mir vorstellen dass es nur bei den Upgradern Probleme gibt, aber auch nicht unter allen Umständen, da es bei mir z.B. das Problem gar nicht erst gab.

    Antworten 
  •  Sven sagte am 24. August 2011:

    Ich hatte das Problem schon unter Snow Leopard und unter Lion ist es noch nicht besser geworden. Das MacBook Pro hat manchmal nach dem Aufwachen aus dem Standby eine Verbindung zur Fritzbox und manchmal keine. Es sucht, aber findet kein Netz. Bisher hat es immer geholfen, Wi-Fi auszuschalten und wieder einzuschalten, dieses manchmal auch 2-3 mal und das Netz ist wieder da.

    Antworten 
  •  fassi sagte am 24. August 2011:

    bei mir trat das problem ebenfalls schon unter snow leopard auf. unter lion ist es nicht besser. ein paar minuten funktioniert die verbindung, doch dann ist “schicht”. wlan kurz deaktiviert, dann aktiviert und man darf wieder für ein paar minuten das wlan nutzen. sehr mühsam und nervig! hoffe auf baldige lösung seitens apples …

    Antworten 
  •  XPert sagte am 24. August 2011:

    Also bei mir funktioniert der Workaround auch am Tag drauf noch wunderbar. Wichtig sei wohl vorallem Router/Accesspoint/AirPort neuzustarten.

    Antworten 
  •  M sagte am 24. August 2011:

    dankö!
    mag mich täuschen, aber zumindest meine Anzeige für die Akku Laufzeit passt auch so langsam wieder ins normale Macbook Pro Bild ..

    Antworten 
  •  sirdir sagte am 24. August 2011:

    Nützt nichts, längst probiert. Viel wird im PRAM eh nicht mehr gespeichert Siehe hier: http://support.apple.com/kb/HT1242?viewlocale=de_DE
    kurz:
    “Anders als bei älteren Mac OS Versionen werden unter Mac OS X keine Netzwerkeinstellungen im PRAM gespeichert. Wenn ein Netzwerkproblem auftritt, schafft das Zurücksetzen des PRAM keine Abhilfe.”

    Antworten 
  •  Olli sagte am 26. August 2011:

    Habs ausprobiert und siehe da, seitdem keine Probleme mehr! Danke für den Tip!

    Antworten 
  •  Michael sagte am 31. August 2011:

    Alle Problemlösungen probiert doch anstatt besser zu werden scheint sich das Wlan Problem bei mir sogar noch zu verschärfen. Bislang half bei mir einfaches deaktivieren und wieder aktivieren. Inzwischen bekomme ich eine Fehlermeldung, dass keine Hardware vorhanden ist. Neustart funktioniert dann nur über langes betätigen des Ausschalters.

    Nach über einem Monat hat Apple die Probleme mit Lion noch immer nicht im Griff. Echt schlechte Leistung. Habe inzwischen gar keine Lust mehr meinen Mac anzuschalten, da ständig dass ein oder andere Problem auftritt.

    Ich will den Schnee-Leoparden zurück….Nur der zeitliche Aufwand hindert mich daran.

    Antworten 
  •  Markus sagte am 31. August 2011:

    Hallo,

    vielen Dank für den Tipp. Bin schon wahnsinnig geworden und hätte echt nicht erwartet, dass Apple sowas released. Jetzt läuft es wieder so, wie man es erwarten würden – toitoitoi, dass es hält. Nochmals Danke

    Antworten 
  •  Frank sagte am 1. September 2011:

    Hi Stefan,
    ich habe seit Update auf 10.7.1 das WLAN-problem mit meinem nagelneuen imac I7. Der Mac stellt die WLAN Verbindung her, dann lässt sich aber z.B. keine Seite in Safari, Chrome odr Firefox aufbauen. erst eine Deaktivierung von WLAN und Wieder-Aktivieren bringt kurz Besserung – dann hakt es wieder. Mein Router ist ein Telekom Speedport 920V. Alle anderen Macs (Snow Leopard) und das ipad und iPhone funktionieren problemlos. Nur eben der neue iMac mit Lion nicht. Kan ich Cmd+Alt+P+R beim Einschalten auch beim iMac anwenden? Dann würde ich das mal ausprobieren …
    Grüße
    Frank

    Antworten 
    •  stk sagte am 1. September 2011:

      Ja, der Cmd+Alt+P+R sollte auf jedem Mac funktionieren.

      Antworten 
  •  Kulturchaot sagte am 23. September 2011:

    Ich behelfe mich im Moment während länger andauernder Arbeit im Internet damit, im Hintergrund permanent einen X-beliebigen Server anzupingen (beispielsweise macnotes.de *hehe*). Damit kommt es zu keinen Unterbrechungen des WLAN. Eine Lösung kann dies jedoch trotzdem nicht sein. Also APPLE, macht was!

    Antworten 
  •  Tom sagte am 30. Oktober 2011:

    Hatte das Problem das mein MacBook Pro nach dem aufwachen sich nicht automatisch wieder mit WLAN verbunden hat. Als ich im Schlüselbund den wlan zugriff komplet gelöscht habe und dannach wieder verbunden hats geklappt und keine weiteren Probleme

    Antworten 
  •  david sagte am 3. Dezember 2011:

    seit 3 tagen auch dieses sch… problem mit dem wlan nach dem Ruhezustand. Mein Macbook pro 13” mitte 2011 braucht gute 2 min nach dem Ruhezustand bis ein Internetzugriff steht. Habe einen airport express. Also am Router sollte es nicht liegen. iphone und andere notebooks laufen auch normal. Auch in der Firma habe ich das selbe Problem. egal ob Kabel oder wlan. auch dieser cmd+alt+r+p bringt nichts.*kotz*

    Antworten 
  •  david sagte am 4. Dezember 2011:

    hab diesen cmd+alt+r+p move jetzt ca 5 bis 6 mal wiederholt. siehe da. schon geht es.:-) naja so freut man sich über sachen die eig selbstverständlich sein sollen….

    Antworten 
  •  Andy Bee sagte am 10. Februar 2012:

    Mein MacBook braucht immer ca. 5 bis 10 Sekunden nach dem Standby um die Verbindung wieder herzustellen.
    Ich habe ein MacBook late 2008 mit frisch installiertem Lion (jetzt Version 10.7.3)
    Mehrmaliges Neustarten mit Cmd + Alt + P + R hat bei mir leider nix geholfen :-(

    Antworten 
  •  Hermann sagte am 16. Februar 2012:

    Habe das gleiche Problem nach Ruhezustand mit meinem IMac. Hab schon mehrere Stunden mit Supportdiensten verbracht. Es ist ein Softwarefehler, an dem die Techniker arbeiten. Wollte mein IMac umgetauscht haben, geht nicht.

    Antworten 
  •  chameleon8811 sagte am 28. Februar 2012:

    Ich hatte gleich nach der Installation von OSX Lion auf externer Festplatte (Snow Leopard ist noch auf interner HD) das Problem, das unter Lion das Wi-Fi Logo in der Menuleiste verschwunden ist…und ich es auch nicht in den Systemeinstellungen unter Netzwerk auswählen kann. Unter Snow Leopard erscheint das Logo schon, aber beim Draufklicken kommt die Meldung “Keine Airportkarte installiert”. Ein PRAM Reset hat auch nichts gebracht…habt jemand schon Erfahrungen damit…? iMac 3.06GHz Intel Core 2 Duo, 4Gb – Lion 10.7.3 mittlerweile, aber hat auch nichts gebracht))

    Antworten 
  •  Marius sagte am 25. Mai 2012:

    Vielen Dank!!! mein WLan hat mich kirre gemacht!

    “Der Hotkey Cmd+Alt+P+R beim Starten leert den PRAM und den NVRAM” hat mein Problem gelöst, vielen Dank!

    Antworten 
  •  Uwe sagte am 26. Juni 2012:

    Hallo,
    ich hatte auch das Problem, dass sich bei meinem neuen macbook air (mitte 2012) nach dem “Aufwachen” keine WLAN Verbindung mehr da war und sie erst neu verbunden werden musste.
    Ich habe nun die Reihenfolge der Netzwerke in den Einstellungen “Netzwerk” geändert und zwar das Netzwerk an erste Stelle, in dem ich mich gerade befinde. Seit dem verbindet sich das macbok air sich regelmäßig wieder mit dem WLAN nach wenigen Sekunden.

    Antworten 
  •  tom_t sagte am 27. Juli 2012:

    Ich habe eine neue FritzBox 7330 SL bekommen. Und prompt ging mit Lion 10.7.4 nix mehr. Nach Umstellung der FritzBox auf 802.11 b+g ging es dann. Alle anderen Maßnahmen führten zu keinem Erfolg. Und das bei einem 2011er iMac der eigentlich hohe WLAN Speeds können sollte. Hier hat Apple dringend was nachzuholen. Mal sehen was der Berglöwe kann, denn dann lohnt sich der Upgrade

    Antworten 
  •  petey sagte am 25. Januar 2014:

    der Hammer, funktioniert heutzutage immernoch mit mountain lion mac air :) danke

    Antworten 

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Werbung
© 2006-2015 Macnotes.de.