MACNOTES

Veröffentlicht am   Uhr von  

Springboard Crash, Safe Mode nach iOS 4.0 Upgrade und Redsn0w-Jailbreak

Home Forums iPhone, iPad, iPod & Co. iPhone und iPod Touch Springboard Crash, Safe Mode nach iOS 4.0 Upgrade und Redsn0w-Jailbreak

This topic contains 5 replies, has 0 voices, and was last updated by  Anonymous 4 years ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #174271

    Anonymous

    So, ich mach mal ne Fehlereingrenzung. Leiden eines Jailbreakers :)

    iPhone 3G, simlockfrei, O2, vorher JB auf 3.1.3, jetzt iOS4 und aktueller Jailbreak mit Redsn0w wie hier beschrieben.

    Nachdem Cydia heute tagsüber kaum zu benutzen war, schaffte ich heute abend die Updates runterzuladen. Die per Default mit dem aktuellen Redsn0w-Cydia installierten Tools waren anschließend alle auf dem aktuellen Stand.

    Nun APTbackup installiert und gestartet. Angesichts einer recht langen Latte von Jailbreak-Apps wunderte ich mich nicht wirklich, dass es fast eine Viertelstunde brauchte, bis der Restore durch war und das iPhone den Reboot machte.

    Auf den Reboot folgte anschließend reproduzierbar permanent der Springboard-Crash mit anschließendem Safe Mode. Reboot, Respring, egal – das Springboard startet und crasht, noch bevor man die SIM entsperren kann.

    Im Safe Mode meldet Cydia keine anstehenden Updates der nun via APTBackup eingespielten Apps, aber erreicht nach wie vor nicht alle Sourcen (Cache-Fehler meist oder Host unreachable). Weiter sind *alle* Icons (ausser Cydia selber, das nach seinem eigenen Update wieder normal aussieht) nur weiße Felder mit den Icon-Rundungen und Glossy-Effekt.

    Ich gehe davon aus, dass eben *bestimmte* Apps das Springboard abschießen, weil sie noch nicht auf iOS 4.0-Kompatibilität gebracht wurden. Ich hab nun angefangen, sie nach und nach im Safe Mode zu deinstallieren, um den Fehler mal einzugrenzen. Bisheriger Stand (ich weiss noch nicht, ob ich da heute noch zum weitermachen komme):

    - WinterBoard deinstalliert. Springboard crasht weiterhin, aber immerhin sind jetzt alle Icons wieder normal.
    - Schweren Herzens SBSettings deinstalliert. Keine Veränderung.

    Bisheriges Zwischenfazit: an denen beiden liegts zumindest nicht *nur*.

    Weitere Kandidaten, die ich wegen iOS4-Featuredoppelung für “crashanfällig” halte, die ich aber noch nicht runtergeworfen hab:
    - Backgrounder
    - Multifl0w
    - Circuitos/Activator
    - (evtl.) ScreenSplitr

    Wer auch an ähnlichen Fehlereingrenzungen sitzt – bitte gerne einwerfen :)

    #183452

    Anonymous

    Hallo Richi

    Mit dem exakt gleichen Problem, das Du hier schilderst, lebe ich derzeit auch! Ich bin neben bei gerade daran einzelne Tools zu deinstallieren, doch bisher erfolglos. Um Zeit zu sparen, habe ich mir nun von meiner App-Übersicht jeweils Printscreens gemacht, notiere ich mir zudem sämtliche Sources und spiele die Custom Firmware nochmals drauf.

    Ist sicher einfacher als den Fehler im Detail zu suchen. Zudem habe ich nachher ein sauberes System ohne irgendwelche “Abfälle” von deinstallierten Programmen.

    “Unser Problem” habe ich nun noch 1:1 in anderen Foren platziert. Sollte ich an Antworten kommen, melde ich mich wieder.

    So long
    Harry

    #183449

    Anonymous

    Hoi,

    ich denke auch, dass es darauf rausläuft. Ich hab nun noch Circuitos, Slider Text Kill und die TVOut-Apps runtergeworfen, kein Resultat. ich frage mich grade auch, ob eine eventuell nicht 4.0-kompatible Cydia-App immer sauber deinstalliert. 5IconDock wollte ich noch runterwerfen, nur taucht das gar nicht (mehr?) unter den installierten paketen auf. Möglich, dass es mit Winterboard runtergeworfen wurde. Ebenso backgrounder. Einfach nicht da – aber definitiv nicht explizit entfernt.

    Angemerkt: Cydia-Updater war heute morgen endlich wieder richtig rund zu erreichen. Update gabs eines für LockInfo, eingespielt, keine veränderung. Lockinfo runtergeworfen, dito.

    Ich glaube auch, dass die Neuinstallation und der verzicht aufs APTUpdate die bessere und schnellere Lösung ist. Ärgerlich, aber absehbar. Wär halt ein glücksfall gewesen, wenns wirklich nur an einer ganz spezifischen App gelegen hätte. Der versuch wars wert :)

    #183453

    Anonymous

    Hallo Richie

    Ich habe nun heute über Mittag die Custom Firmware nochmals draufgehauen und mit meinen Screenshots, die ich vorab auf den PC gehauen habe, wieder installiert. So begann ich nun einzeln die Apps wieder draufzuhauen. Es lief alles perfekt, bis ich “infinidock” draufpackte. Wieder hatte ich den Stress mit Springboard. Rausgeschmissen und gut war. Danach gleiches Problem mit Lockinfo. Interessant, dass es da ein Update gibt, wie Du schreibst, doch ich warte mal noch etwas. :-)

    Meine Mühle läuft wieder super und ich bin happy. Tat nicht weh und ging ganz schnell im Gegensatz dazu, dass ich gestern Abend um 23.00 Uhr begann von iOS 4.0 auf 3.1.2 zurückzuflashen (da ich mit Spirit gebreakt hatte), dann die Custom Firmware erstellte und draufpackte. Hatte unzählige Probleme und um 2.00 Uhr war ich fertig (fix und fertig). Also – kein Thema mit den Sources, oder? :-)

    Viel Erfolg.

    Gruss
    Harry

    #183450

    Anonymous

    Infinidock! Grossen Dank für den Tipp! – Der Witz ist, dass ich das definitiov nicht installiert hattem dafür aber infiniboard. Richtig wieder hergestellt wurde es nicht (vielleicht, weil commercial package), aber ich vermute einfach, dass es da *irgendwas* wiederhergestellt hat. infiniboard wird bei mir jedenfalls nicht als installiert angezeigt in Cydia, war es aber definitiv.

    Ich wage jetzt einfach mal den Tipp, dass insbesondere gekaufte Cydia-Apps bei der Wiederherstellung Probleme machen könnten und der Haken gar nicht bei den apps liegt, die nach einspielen der APTBakup-Backups in Cydia *da* sind, sondern die, die eben *nicht* wieder angezeigt werden.

    ich schätze mal, bei mir läufts dann auch auf nen neuen restore nach dem Spiel heut abend raus :)

    Grossen dank für deine hilfe!

    #183454

    Anonymous

    Also bei mit lag es schlicht und ergreifend an “LockDown”, welches via Cydia installiert war. Nach der Deinstallation davon gab es bei mir keine Crashs mehr. Ich habe ebenfall die 4.0, unlocked, benutze Base.

    #183451

    Anonymous

    Fürs Protokoll: ich kann grade aus Gründen des iPhne4-testens das nun immerhin neu aufgespielte iOS4 auf dem 3G nicht wirklich weiter bearbeiten…

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

 Und wie ist deine Meinung?  Schreib uns einfach!

Werbung
© 2006-2013 MACNOTES.DE. Made with insanely great for all things Mac. Apple.de